Архив за день: 24.10.2014

Пересборка php 5.3.x с клиентскими библиотеками MariaDB 10.x

При работе с текущей стабильной веткой MariaDB 10.x часто возникает проблема несовместимости клиентских библиотек. Выражается это вот так например:

mysql_connect(): Headers and client library minor version mismatch.

На эту тему есть даже отдельная статья по устранению неисправностей при работе с MariaDB из PHP 5. Для всех нормальных людей подходит рекомендуемый совет из той статьи: использовать mysqlnd-драйвер. Однако проблема в том, что старые версии PHP, а именно 5.3.x не имеют этот драйвер в своем составе по-умолчанию. Приходится либо переходить на более новую версию php с ожидаемыми глюками работы древних клиентских сайтов, либо вручную пересобирать клиентские библиотеки PHP. Это кстати один из предложенных способов решения проблемы по вышеприведенной ссылке. Вот как раз второе мы и рассмотрим в этой статье.

Читать далее